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Introduction

Welcome to Maple Systems and EBPro, our easy to use configuration software for our line of HMIs, cMTs, and 
RMIs. This guide will give a brief introduction to what is possible with EBPro using a short project that 
familiarizes you with the basic elements necessary to start programming in EBPro.

If you are still deciding on which manufacturer or product line will best suit your needs, then follow this guide to 
experience just how easy it is to produce high quality interfaces with EBPro. If you are already a Maple Systems 
customer and need to begin working with your new software, use this guide as a starting point. After you have 
run through the Quick Start Project, use the guide as a reference when building your own projects. 

The following flow chart lays out how to build the Quick Start Project in EBPro. The project is broken into simple 
logical steps to make it easier to step back into if you need to step away and to make it easier to reference later 
when you are building your own projects.

Part 1: Provides the necessary tool to create an HMI project 
by downloading and installing EBPro. 

Part 2: Lays the foundation for exploring the software by 
creating a new project in EBPro and saving it to the PC. 

Part 3:  Introduces the structure EBPro uses to organize and 
construct an HMI project: multiple windows. 

Part 4: Builds and configures the fundamental building blocks 
of an automation interface; the inputs, displays, and visual 
elements that create function from form.

Part 5: Explores one of the powerful features of EBPro, the 
offline simulator. 

Part 1: Install EBPro
Page 5

Part 2: Create a Project
Page 6

Part 3: Create Windows
Page 9

Part 4: Create Objects
Page 15

Part 5: Simulate
Page 38
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The Quick Start Project uses an imaginary brewery as a setting. When complete it will have a main screen to 
which the project opens and a detail screen for one of the kettles to which the user can navigate. On the detail 
page the operator can input process set points and see current sensor readings displayed. 

This is how the Quick Start Project will appear when complete:

Conventions

Human machine interfaces (HMIs) are one way for human operators to interact with control systems. The most 
common central processing unit (CPU) in modern control systems is the programmable logic controller (PLC). 
PLCs control electromechanical systems through the input and output (I/O) of electrical signals. Since the 
physical signals in control systems can be broadly categorized as analog or digital, it is helpful to think of the 
virtual program variables in the same categories.

Digital devices, as well as the internal variables associated with them, have only two states; on and off. 
Depending on the manufacturer or software package, this type of variable is also called a Boolean, discrete, 
binary, or bit. Bit is a reference to the single bit of computer memory necessary to hold the value of a digital 
variable.  

Analog devices, as well as the internal variables associated with them, have many possible states. Depending on 
the manufacturer or software package, this type of variable is also called a value, non-binary, register, or word. 
Register is a reference to the memory slot defined in the program to hold the value of the variable. Word is a 
reference to the most common data type for analog variables, the 16-bit word. Analog variables can be stored in 
memory registers of various sizes depending on the type, or size, of the data including: integer, word, double 
word, unsigned long, etc.

Since EBPro is used to program HMIs, it uses the term “input” when referring to the user giving information to 
the system. Examples include the user pressing a button to change the state of a bit or typing a value into a 
keypad to define a process set point. When referring to output from the HMI to the user, EBPro uses the term 
“display.” Examples include displaying the state of a bit with a lamp that appears on or off, or displaying a 
process value from a sensor either with digital text or a graphical representation.

The Quick Start Project includes the following elements:

Main Screen Detail Screen
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• Analog inputs: Used here for temperature and level settings with the EBPro element “Numeric Input.” 

• Digital inputs: Used for starting and stopping the batch with the EBPro element “Set Bit.” 

• Analog displays: Shown as graphic representations of temperature and tank level, also as dynamic text 
showing time. In this project the graphical representation is done with the EBPro element “Bar Graph.” 
The system time is shown using the EBPro element “Date/Time.”

• Digital display: As a lamp showing the batch as on or off using the EBPro element “Bit Lamp.” 

EBPro includes many other programming elements for inputting and displaying variables, as well as more 
advanced operations such as alarming, data logging, trend displays, and animated display elements. To enable 
you to get started quickly, this project will only cover the basic elements necessary for process control.

When you’ve finished this guide, you’ll know how EBPro and Maple Systems can fulfill your automation needs. 
You’ll be ready to build your own dynamic interfaces that will deliver the operational effectiveness and added 
value your customers demand. 
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Part 1: Install EBPro

This section will guide you through the steps to install EBPro onto your computer so you can begin to explore 
the software. 

For more information on installing EBPro see the EBPro Programming Manual (EPM). 

Chapter: Introduction.

Install from Web

Download Files

Download the installation file for the free Full version of EBPro, and the Quick Start Files, from the Maple 
website. 

1. Go to Maple Systems website https://www.maplesystems.com/

2. Go to Technical Support->Software Downloads & Upgrades.
https://www.maplesystems.com/supportcenter/softwaredownloads.htm

3. Download the EBPro Full 
Version software.

4. Downloading from the 
Maple website requires a 
free account.

5. Selecting the download will 
bring up the log in page 
unless the user is already 
logged in. 

6. Register and create an 
account or login to an 
existing account. 

7. Download the EBPro Full Version. 

PART 1: INSTALL EBPro

https://www.maplesystems.com/
https://www.maplesystems.com/supportcenter/softwaredownloads.htm
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Install EBPro

After downloading the installation file, run the install 
utility.

1. Locate the downloaded file EBProSetup.exe. If 
you use the default download folder option in 
Windows the file will be in: C:\Users\***your 
username***\Downloads.

2. Double click the file to run the program.

3. Follow the prompts from the installer to 
choose the install location and complete 
installation. 

   Download and Install Quick Start Files

1. Go to Maple Systems website: 
Technical Support->Sample Projects->Quick start Guide project files.

2. Quick Start Guide Project Files (Works for both EZware and EBPro software) - This zip file contains all of 
the Quick Start Guide project files you'll need to get started.

3. After downloading QuickStart.zip, unzip the files and place them in the proper location.

4. Locate the downloaded file QuickStart.zip, right click on the file and select Extract All.

5. The Extract Compressed (Zipped) Folders dialog opens. Select the location to extract the files to and 
click Extract.

6. Locate the three extracted files; Quick Start Ex.emtp, Quick Start.flb, and Quick Start.glb. If you use the 
default download and extract folder options in Windows the files will be in:
C:\Users\***your username***\Downloads. 

Part 1 complete, you have the software and support files installed and are ready to go. Part 2 will walk 
you through creating your first project. 

https://www.maplesystems.com/cgi-bin/download/xfrfile-sample.asp?f=HMIQuickStartProjectFile.zip
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Part 2: Create a Project

This section guides you through creating a project, exploring the interface, and saving your new project. When 
Part 2 is complete you will have a new project saved on your PC, ready to configure, and you will have a basic 
understanding of the layout of the interface so you know where to look to follow the instructions in later 
sections. For more information on creating a project, see chapter 3 EB pro manual: Creating an EBPro project.

Starting EBPro

1. From the Windows Task Bar, click the Start button, select
 All Programs > Maple Systems > EBPro

The full path of the file installed in the default location is: 
C:\MapleSystems\EBPro\EBPro.exe 

If another location was chosen the path will be: 
**\Maple Systems\EBPro\EBPro.exe

2. The EBPro dialog box appears. 
• Select New

3. Select the HMI model to use in the project. 
• Choose HMI5121P/HMI5150P 

(1024x768). 
• Select Landscape display mode. 
• Check the Use template checkbox.
• Click OK. 



EBPro Quick Start Guide                                                                                                                                                        9

EBPro Quick Start Guide                                                                                                                                                        9

4. The System Parameter Settings window opens next. No more devices will 
be added and the default settings will be used for the Quick Start Project. 

• Click OK to accept the settings.
• For more information, refer EBPro Manual chapter 5: System 

Parameter Settings. 

A blank project has been created and is ready for configuration. It should look like this: 

EBPro Interface

The EBPro interface default configuration uses three main regions:

• Region 1, at the top, is referred to as the Menu Area. The Menu Area includes the top menu bar and 
ribbon is the default area where ribbon options are selected. 

• Region 2, on the left, is referred to as the Window Tree. The Window Tree has multiple tabs and display 
options to show the windows in the project, which objects exist on those windows, and to which 
addresses those objects are linked. 

• Region 3, on the right, is referred to as the Main Screen. The Main Screen is where most of the work is 
done within EBPro. All currently open windows are displayed in the Main Screen and most placements 
and modification of objects is initiated here.
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Saving the Project

Before making any changes, save the project. From the top menu bar select File -> Save As. The Save As dialog 
opens. 

1. Navigate to C:\MapleSystems\EBPro\project. 
2. Name the project Quick Start.
3. Click Save.
4. Save frequently to protect completed work.

With Part 2 complete, you now have a new project created and saved on your PC. You now know how to create 
your own projects when you are ready, and you’ve been introduced to the basic layout of the interface so you 
can follow the instructions in the following sections of this Quick Start Guide or in the EBPro Programming 
Manual. Part 3 will walk you through creating new windows and adding buttons for the operator to navigate 
between them. 

Part 3: Create Windows
Next the Quick Start Project introduces the user to the configuration structure in EBPro. EBPro lets you program 
on multiple windows that can display to the operator individually or stacked together as a single screen. The 
operators that use the interface can see any screen accessible to a user with their access level. They can jump 
between screens using buttons or be taken to different screens in response to system conditions. Stacking 

MAIN SCREEN

TOOL BAR

WINDOW 
TREE
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multiple windows into a single operator accessible screen can simplify the design process. For example, create a 
single window with the company logo and colors made into an appealing border then set that as a background 
for all the other windows. This saves the time of adding the logo to each page directly. For more information on 
windows see the EBPro Programming Manual chapter: Creating Windows. 

By the end of Part 3, the project will include three new windows and function keys to navigate between the 
operator accessible windows. It will look like this:

New window

EBPro uses the term window to refer to the screens that can be displayed or programmed in the HMI. By 
default, EBPro uses Window 10 as the startup window that is displayed whenever the HMI powers up or 
reboots. When a project is created with the template file, it starts with the default window and a number of 
windows for specialty functions such as keyboards and error messages. The Quick Start Project will use five 
windows. One is a keypad that is included in the template; it will be used but not modified. The default window 
has already been created and will be modified in the project. Finally, three new windows will be created. One 
will be a detail page for the user to navigate to for more information and system control.  The final two windows 
will have background images for the two operator accessible windows. Before creating new windows, change 
the Window Tree to the Object List view.



EBPro Quick Start Guide                                                                                                                                                        12

EBPro Quick Start Guide                                                                                                                                                        12

1. At the bottom left of the Window Tree select the Windows tab.

2. At the top of the Window Tree, the drop-down list shows Window 
Preview is the current view. Click the drop-down menu and select 
Object List to change the view. 

Now that the Window Tree is displaying the Window tab with the Object List option, three new windows will be 
added to the project. With the Object List selected the Window Tree displays a 
list of all the used and available windows in the project. Double clicking on any 
window will open it in the Main Screen. 

1. Left click on 11 in the Object List. Right click and select New.

2. The Window Settings dialog opens. All settings will be left default for 
now. The default window names can be changed for easier reference, 
but this is not necessary in such a small project. Click OK.

3. Repeat steps 1 and 2 to create Windows 12 and 13. 
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Navigating windows

Now that the project includes multiple windows, the operator needs a 
way to navigate between them. Function Key objects will be added to 
the windows to switch between them. In EBPro, objects are the 
elements placed on the windows or created in the project to complete 
a task. Objects can be static, such as background images and fixed 
text, or dynamic, such as lights that change color to indicate the state 
of a bit. Some static objects, like basic shapes, can be drawn directly 
on the window, but most will use a visual element chosen from the 
libraries. There are three types of libraries that store visual elements. 
The Shape Libraries store vector graphics constructed of lines, curves, 
or polygons. New shapes can be created using the drawing tools under 
the Draw menu. The Picture Libraries store bitmap graphics and 
accept a range of file formats including .gif, .jpg, and .png. EBPro 
comes preloaded with numerous shape and picture libraries, as well as 
the tools to easily import new elements and create new libraries. The 
Group Libraries store objects constructed of multiple shapes and 
pictures. 

1. Navigate to Window 10. Double click on Window 10 in the Object List or select the Window 10 tab at the 
top of the Main Screen if it is already open.

2.  From the top menu bar select:

                Object -> Function Key. 

3. The New Function Key Object dialog appears. Click the Comment field on the General tab. Type BREW 
to identify the function key. Ensure Change full-screen window is selected. Window no. is where the 
window to be displayed by the function Key is selected. The drop-down list shows the number and name 
of all available windows. If it is not already selected, choose 11. Window_011
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4. Select the Shape tab. 
• Uncheck Use Shape.
• Check Use Picture.
• Click Picture Library to open the Picture 

Manager
And select the picture to use for the 
function key.

5. Select the Library tab in the Picture Manager.
• Click New Library to attach a new library to the 

project.

6. Browse to Quick Start.flb. (The default location 
for EBPro libraries is: 
C:\MapleSystems\EBPro\library\legacy)

• Click Open to attach the library to the project. 
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7. In the Quick Start library select image 3. 
• Click OK to select the grey button and return to 

the object properties dialog.

8. Now that the picture is selected change to the Label tab.
• Check the Use Label checkbox. 

• Select Arial Bold for the Font.

• Select 24 for the Size.

• Select Dark Blue for the Color. 

• In Content, type BREW. 

• Click OK.   

9. The object appears as a white outline on the window. Place 
it near the bottom right corner by left clicking. Once placed 
the object appears on the screen. 

10. Copy the function key to Window_011.
• From Window_010 select the function key. 
• Press ctrl + c, or right click and select Copy. 
• Open Window_011 by double clicking 11: 

Window_011 in the window tree object 
list. 

• Press ctrl + v, or right click and select Paste. 
By default, the new object gets the same 
position as the object copied. 
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11. Change the properties of the new button. To modify an 
object: 

• Double click on it.
• Or left click to select, and then right click to bring up the 

quick menu and select Attribute.
• On the General tab change Comment to Home.
• Ensure Window no. is set to 10. WINDOW_010. 
• On the Label tab change the Content to HOME.

o Click OK.   

12. The project should now look like this.  

With Part 3 complete, you should now understand how EBPro structures a project and how an operator can 
access the different windows that make up the project. You have also seen how to associate a library element to 
an object on the screen to quickly give it the visual effect integral to the modern user interface. Part 4 will 
continue by guiding you through creating the additional programming elements necessary to complete the 
Quick Start Project. 
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Part 4: Create Objects

In this section you’ll create the basic elements that your end user will see and interact with to control their 
system. The section is broken up into five sub-sections for easier organization. You will begin with the static 
elements such as text and images. The remaining four sub-sections cover the primary four functions of an HMI; 
digital input, digital display, analog input, and analog display.

You will create: 

• Numeric Input Objects for the operator to enter set points for temperature and tank level. 
• Bar Graph Objects will show the readings from the temperature and level sensors in a graphical 

form. 
• A Date/Time Object will show the system time, as a digital clock, on the home page. 
• Set Bit Objects, in the form of start and stop buttons, allow the user to turn the process on and 

off. 
• A Bit Lamp Object using the image of a lamp with text will show the user the current state of 

the process. 

For more information on objects see the EBPro programming manual: Using EBPro

When Part 4 is complete, the project will be ready for simulation. The two operator accessible windows will look 
like this:

Static Elements
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This sub-section will add text and background 

images, when it’s done the project will look like this:

Windows 12 and 13 will have a static image covering the entire screen. Window 10 will use Window 12 as a 
background and the objects on Window 10 will appear in front of the background image. Window 11 will use 
Window 13 as a background. 

1. Open Window_012. Double click 12 in the 
Object List, or left click to select, then right click 
and select Open. 

• From the top menu bar select 
       Object-> Picture.

2. The New Picture Object dialog opens. 
Click Picture Library...to select the image to 
display.
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3. The Picture Manager opens. 
• Browse to the Quick Start.flb library.
• Click Open. 
• Select image 5. 
• Click OK.

   4.  Make sure Set to original dimensions is checked.

• Click OK.
• Left click to place the image. The placement cannot be 

changed because the image is the same resolution as the 
screen.

5. Repeat steps 1 through 4 to place image 6 from the Quick Start 
library on Window_013. Image 6 looks like image 5 with a menu 
area on the left.

• In the Object List click on WINDOW_010 to select it then 
right click to open the selection menu.

• Select Settings. 

6. The Window Settings dialog opens. 
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• In the Underlay window section, use the drop-down menu 
to select 12. Window_012, for the Bottom underlay. 

• Click OK. 

7. Window 10 should now look like this. It 
looks almost the same as Window 12, but 
with the previously added function key in 
front of the background image. 

8. Repeat step 6 to select Window_013 as the background for 
Window_011.

9. Add text to Window 11. With Window 11 open, from the top 
menu bar, select 

    Object -> Text (A). 

10. The New Text Object dialog opens. 
• Change the Font to Arial. 
• Change the Size to 18.

• Change the Color to Dark Blue.
• Change the Content to MIXER CONTROL.
• Click OK and place the text on Window 11 in the upper menu area. 
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11.  To add additional text, repeat step 9 or copy and paste the existing text then double click the new text 
to change the properties. Window 11 will have the following text:

• TEMPERATURE: size 18.
• TANK LEVEL: size 18.
• °F: size 24, Arial Bold (the degree symbol, °, can be copied from a word processing program or 

created using the alt + number pad shortcut. Hold Alt then on the number pad type 0176, then 
releases Alt).

12. Align and center the menu headings.

• Left click MIXER CONTROL to select the text, then while holding CTRL select TEMPERATURE 
then TANK LEVEL. 

• With all three menu headings selected select Edit -> Align -> Horiz. Center. 
• Now that the headings are aligned, with all three headings still selected use the arrow keys to 

center the headings in the menu area. 

When using the Align, Make Same Size, or Make Same Color commands, EBPro uses the last selected object, 
denoted with red handles ( ) as the reference object and changes the other objects to match. In the image 
on the right, TANK LEVEL was selected last, so it is the reference object indicated by the red handles. 
TEMPERATURE and MIXER CONTROL are shifted to align with the horizontal center of TANK LEVEL.  

With the Static Elements sub-section complete Windows 10 and 11 should look like this:

Digital Inputs

In this sub-section, two inputs will be added to the detail 
page for starting and stopping the batch. For this Quick 
Start, we will only deal with two variable types, local word 
(LW, analog variable stored in the HMI) and local bit (LB, 
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digital variable stored in the HMI). A live project would have objects linked 
to variables both locally and in a connected PLC, but in the Quick Start 
Project, elements will be linked directly to each other within the HMI. For 
more detailed information on specific memory addresses used in the HMI 
go to the EBPro Programming Manual chapter 22 – “System Registers”.

When the digital inputs and displays are complete 
the detail page, Window 11, will look like this:

1. Add a START button. With Window 11 open, 
from the top menu bar select
                Object -> Button -> Set Bit

2. The New Set Bit Object window opens. 
• In the Comment field, name the object Start. 
• The Write Address section will be left at the default 

address LB-0. 
• The Set Style will be left at the default Set ON. 

3. Select the Label tab.
• Check Use Label.
• Set the label attributes to: Font – Arial Bold, Size – 24, 

Color – White.
• Type START in the Content field. 
• Click OK
• Left click and place 

4. Right click, select Attribute. The Picture Manager opens. 
• Browse to the Quick Start.flb library.
• Select image 1, the green button. 
• Click OK to return to the object properties. 
• Click OK.
• Resize as needed. Place the button in the top left menu area 

on Window 11.

5. Create another button by repeating step 1 or copy and paste 
the first button. 
• Place it directly underneath the start button.

6. Change the properties of the new button. 
• In the Comment field, change the name to Stop.
• Change the Set Style to Set OFF. 
• On the Label tab, change the Content to STOP.
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• Select button style 2, the red button, from 
the Quick Start library. 

Digital Display

1. In this section a bit lamp will be added to 
show the state of the bit controlled by the input buttons.
Add a digital display indicator light. 
From the top menu bar select 

     Object -> Lamp -> Bit Lamp.

2. The New Bit Lamp / Toggle Switch Object opens. 
In the Comment field, name the object Run Indicator.
The Read Address section will be left at the default address LB-0 (this bit lamp will read the bit 
controlled by the two input buttons). 
On the Shape tab select Use Picture. 
Click Picture Library to browse to the desired image for the button.

3. The Picture Manager dialog opens.
• Browse to the Quick Start library.
• Select image 0. 
• Notice on the right-hand side there is a preview of the two states of the image. 
• Click OK to select the image and return to the object dialog. 
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4. On the Label tab select Use label. This lamp will indicate two states so two labels will be used. 
• For State 0 set the Attributes to: Font – Arial Bold, Size – 24, Color – Black. 
• Change the Content to OFF. 
• Change the State to 1 by using the arrow key, clicking the 1, or by using the State drop down menu. 
• For State 1 change the Color to Yellow.
• Change the Content to ON. 
• Click OK.

5. To test the lamp to see how the two states appear click on Home and on the right side of the ribbon 
menu look for a section titled “State/Language”.

• From State/Language, you can alternate between the first two states by clicking on S0 and S1.
• Click on S0 to switch the state to OFF.
• Click on S1 to switch the state to ON.

(Ex. A digital variable used for run indication might be programmed to read “running,” for state 1, and 
“stopped,” for state 0. An analog variable might be programmed for a dozen different states to communicate 
the twelve different error codes read from that variable.)

6. Toggle the state of the window from 0 to 1 and back. Using the State Toolbar, switch the state by 
clicking the arrows left and right, clicking the number of the desired state, or using the drop-down menu 
to select the desired state. The drop-down menu is necessary for testing analog variables with more 
than 5 states. 

The two states of the digital inputs and displays should look like this: 
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With the Digital Input and Digital Display sub-
sections complete Window 11, the detail page, 
should now look like this:

Analog Inputs

Setting the value of an analog variable from the HMI can happen in a variety of forms. Push buttons on the 
screen can change a variable to a specific value or increment the value up or down a set amount for each button 
push. A slider can vary an analog variable through any defined range. Another method is to directly input a 
desired value using a Numeric Input. The Quick Start Project uses two Numeric Input Objects that use a keypad. 
One is for the temperature set point and the other is the tank level setting. Each of these objects will use one of 
the pre-loaded keyboards built into the template file. When the user selects the field for input by clicking on it, a 
pop-up window will appear on the screen with the selected keypad for entering data. After the user enters the 
value, the keypad closes until called again. This saves valuable screen space and allows larger, easier to use 
keypads.

When the analog input sub-section is complete, Window 
11 will look like the image on the right.

1. Add numeric inputs for setting the tank level and 
temperature. From the top menu bar select: Object -
> Numeric
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2. The New Numeric Object dialog appears.  
• In the Description field name the object Level Setting. 
• Ensure the Allow Input box is checked.
• In the Read Address section, change the address to 

LW-10. Use the drop-down menu to select the 
variable type, LW, and then type 10 into the input 
field to select the variable address.

3. Select the Data Entry tab. 
In the Keyboard section set Window no. to 50. Keypad 1 – 
Integer. 

4. Select the Format tab. 
In the Number of Digits section, change Left of Decimal Pt.    
to 3

• In the Limits section, change ‘Device High’ to 100. 

5. On the Shape tab, uncheck Use shape. Click OK to place 
the object on the screen.

• Place it in the Tank Level menu area next to the 
% text.

6. Draw a picture and place it behind the Level Setting text 
to frame the input field.
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• From the top menu bar select Object -> Picture, Click Picture Library... to select the image to 
display.

7. The Picture Manager dialog opens.
Browse to the Quick Start library.
Select image 8, the frame. Click OK to select the image and return to the object dialog. 

• Make sure Set to original dimensions is checked. Click OK again and place the image on top of 
the Level Setting input text. 

8. Change the layer of the newly 
placed frame so it is behind the 
input text.
• With the frame image selected, 

from the Home menu, under 
Arrange, select 

Layer -> Bottom Layer

• Now the frame is behind the text, select the Level Setting and % text and use the directional arrow 
keys to center the text inside the frame. 

9. Create another Numeric Input Object for the 
temperature setting by repeating steps 1 through 8, 
or by copying and pasting.
• In the Description field name the object 

Temperature. 

• Ensure the Allow Input box is checked. 

• In the Read Address section change the address to 
LW-20. 

10. Select the Format tab.
• In the Number of Digits section, change Left of 

Decimal Pt. to 3. 

• In the Limits section, change ‘Device High’ to 200 and ‘Device Low’ to 100.

11. Select the Data Entry tab.
• In the Keyboard section set Window no. to 50. Keypad 1 – Integer. 

12. Select the Shape tab.

• Ensure Use Shape is unchecked. 
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• Click OK to place the object on the screen.

• Place it in the Temperature menu area next to the °F text.

13. Place a frame, Quick Start library image 8, behind the input text.

14. Center the Temperature input text and the °F text inside the frame. With the analog input sub-section 
complete, Window 11 should look like this:

Analog Displays

Analog displays from the HMI to the operator can be text based or graphical. The numeric objects created in the 
last sub-section are dual function input and display, but these could be used for display only by unchecking the 
Allow input checkbox. This sub-section of the Quick Start Project creates three new data display objects. Two 
bar graphs for temperature and tank level will be added to Window 11. And a digital clock displaying the system 

time will be added to the main page. 

The tank level indicator will be built onto the background image using another library image and a bar graph. 
Once complete, it will be grouped together and stored in the group library for future use. The thermometer has 
already been built from text, drawings, and a bar graph and is stored in the group libraries. 

When this sub-section is complete, the project will be ready to simulate.

Sometimes it is convenient to work in a space not crowded with previous work. To build the tank level indicator 
a new blank page will temporarily be created as a work space. The tank level indicator will be built on the blank 
page and saved to the group library. Then the work page can be deleted.

1. Pick an unused window number and create a new blank page. 
• Right click on any unused window number and select New. 
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• If the new window has a background like Window 10 or 11, change the Underlay window back to 
none in the Window Settings.

• Double click the new window to open it in the main screen. A blank screen is now open as a 
workspace.

2. Place the image for the tank exterior. From the top menu bar select: Object -> Picture.

3. The New Picture Object window opens. 
• Click the Picture Library button to open the Picture 

Manager. 

4. In the Picture Manager browse to the Quick Start library.
• Select image 7, showing the tank exterior, with a breakout for 

the graph. 
• Click OK 
• Place the image in the center of the screen.
• Double click the picture to open the properties and check Set to original dimensions then click OK.

Once the image is placed it should look like this:

5. Next, create a bar graph to indicate the tank level. From the top menu bar select
Object -> Chart -> Bar Graph. 
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6. This opens the New Bar Graph Object. 
Select
 the General tab.
• In the Comment field change the name to Tank Graph.
• Change the Read Address to match the Level Setting 

input address used earlier, LW-10. 

7. Select the Range tab.
• In the Attribute section, change Max Value to 100.
• In the Target Indicator section, uncheck Enable.
• In the Alarm Indicators section, change High Limit to 101. 

8. Select the Shape tab.
• Uncheck Use Shape. 
• Leave the rest of the settings default.
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• Click OK and place the graph so the top right corner is aligned with the 100 mark on the right side of 
the tank breakout. 

With the graph placed, the screen should look like this: 

9. Adjust the bar graph to cover the tank breakout. When an object is selected, it has eight sizing handles 
around the outer edge. Click and drag one of the sizing’s handles to stretch the object. Click and Hold 
the bottom left sizing handle, and then drag it until the bottom of the graph aligns with the 0 mark on 
the right side of the tank breakout, and the left side of the graph completely covers the tank breakout.

10. Change the layer so it is behind the tank exterior image. 
• With the graph selected from the 

Home menu, under Arrange, select: 
Layer -> Next Layer. 

With the image and the bar graph placed, 
stretched, and properly layered it should look 
like this:

11. Group the pieces together. 
Click and drag a selection box around the entire area or, from the Home menu, select 
  Select -> Select All Objects.
With all the pieces selected together, from the Home menu, select 
  Arrange -> Group.
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12. Open the Group Library dialog. 
From the top menu bar click on Project -> Group

13. This opens the Group Library dialog. Click Select 
Lib... and Navigate to 
C:\MapleSystems\EBPro\library\legacy\quickstart.glb

14. Now the library is attached to the project, save the tank level group to the library. 
• With the group selected, from the top menu bar, select 

            Project -> Group -> Save to Group

15. The Save to Group dialog opens. 
• Set the Group library to Quick Start. 

• In Comment enter tank graph. 

• Set Group no. to 2. 

• Click OK. The new group is now shown in the 
selected spot in the library. It should look the 

same as group 1.

Click Exit to close the Group Library dialog
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16. Return to Window 11 to place the newly created group. 
• From the top menu bar select Project -> Group 

• From the Quick Start library, select group 2: tank graph.

• Click Place and place the group on top of the tank 
background image.

17. Aligning the group perfectly is necessary to make the 
images match up. 
• Click and drag the group with the mouse to get it close to 

the correct position. 

• Then with the group selected, use the 
keyboard directional arrow keys to complete 
the alignment. 

• With alignment complete it should look like 
this:

18. Place the previously created thermometer group 
into the project. 
• From the top menu bar select Project -> Group 

• From the Quick Start library, select group 0: 
thermometer.

• Click Place. 

• Place the group in the temperature section. 

• With the thermometer placed it should look like 
this:

19. Address the new thermometer to the correct 
variable.

• Double clicking on a group brings up the Address dialog. 

• Select the piece of the group to modify, in this case the group only has one element to change: bar 
graph 1 (BG_1), then click Settings...

20. This opens the Bar Graph Object Properties dialog.

• Ensure the Read address is set to LW-20, the address used for the temperature input. 

• Click OK, to accept the changes.

• Click Exit from the Selected Objects menu
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21. Place the final object, a 

clock, on the main page.
• On Window 10 from the top menu bar select

Object -> Time-Related -> Date/Time 

22. The New Date/Time Object dialog opens. Select the General tab. 

• Uncheck Enable in the Date section.

• Uncheck Enable in the Day of Week section. 

• Change the Font to Arial Bold.

• Change the Size to 36.

• Change the Color to Dark Blue. 

23. Select the Shape tab.
• Uncheck Use Shape.

• Click OK.

• Place the clock in the lower left of the screen. 

The project is now complete and ready to simulate. Windows 
10 and 11 should look like this:

With Part 4 complete, you now have the basic tools to create a beautiful and functional operator interface. 
You’ve created analog and digital inputs and displays so you can control and monitor any process variable. Now, 
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the only remaining step is to test the system and see it in action. In step 5, you will run the newly built interface 
through the simulator to see how it will appear to the end user.
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Part 5: Simulate
The ability to fully simulate and test a project from the configuration software accelerates the testing and 
revision process. To test the project function, or to see how different object settings will appear to the user, the 
project needs to be simulated. EBPro offers Online and Offline simulation. Online simulation connects the 
simulated HMI, in the PC, to a live PLC to test how the project will interact with the system. Offline simulation 
runs the simulated HMI, in the PC, without a PLC connection. The last part of the Quick Start Project is to 
complete testing in an offline simulation. For more information on simulating see the EPM chapter: Simulator 
Mode.

Compile

1. Save the project. 
2. From the Project menu bar, select
 File -> Save, or use the Save icon. 
3. Compile the project. From the Project menu, 

select Compile. 

The Compile dialog opens. 

• Click Compile. After the project has compiled a summary will show if any errors or warnings were 
generated.

• If the project compiles without error, 
click Close. (If any errors are encountered 
double clicking the error will bring up the 
properties for the object that caused the 
error. Go back to the section of the Quick 
Start Guide for that element to find the 
correct settings to fix the issue.)
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Simulate

1. Open the offline simulator. From the Project menu, select Offline Simulation. 

2. The simulator opens to the startup 
window; in this case, Window 10. It should 
look like this:

3. Click Brew to go the detail page, Window 11. 
It should look like this:
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4. Change variables to see the graphics react.
Click on the temperature input to bring up the 
keypad. 
Type 150 then Enter. The value in the input 
field will change and the thermometer now 
reads 150 as well.
Click on the level setting to bring up the keypad 
again.
Type 45 then Enter. The value in the input field 
changes and the tank level indicator shows the 
current level.
(Entering values within the range specified for 
the input in numeric limits will change the 
value. Attempting to enter a value outside the specified range will not change the current value.) 

5. Click the start and stop buttons to see the run 
indicator lamp change state. 
After the project has been completely tested, 
close simulation by clicking the red X at the 
top right of the simulation window or right 
click and select Exit simulation.

Thank you for taking the time to explore EBPro, and congratulations on completing the Quick Start Project. You 
have now seen how easy it is to create a visually appealing interface with EBPro. When it is time to build your 
own project, use this guide as a reference tool to help remind you where to find the necessary elements. If you 
need any further information about Maple Systems or the products we offer, please contact us and we will be 
happy to assist you.
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More information
Maple Systems delivers the industry’s best value in control products. For us, “best value” means high quality 
products and outstanding service at a great price. In addition, all products are backed by an outstanding team 
and complimentary technical support. 

Contact Us:

Contact our automation experts today.

• Phone:      425-745-3229
• Email:      support@maplesystems.com
• Website:   https://www.maplesystems.com

Program Information:

Help Files: 

• From the File menu select Help Topics. The How do I... section includes instructions for common tasks. 

EBPro Programming Manual:

• In the Help files: Help -> Manuals and PLC Connection Info -> Programming manual. 
• From the Start Menu: All Programs > Maple Systems > EBPro > Programming Manual.
• Download from the Manuals page at: 

https://www.maplesystems.com/SupportCenter/Manuals&Guides.htm (login required).  

Tech Notes:

• Get step by step guidance in building specific elements or solving common automation issues from our 
extensive library of technical notes at: 
https://www.maplesystems.com/SupportCenter/TechnicalNotes.htm (login required).

COPYRIGHT NOTICE

This manual is a publication of Maple Systems, Inc., and is provided for use by its customers only. The contents 
of the manual are copyrighted by Maple Systems, Inc.; reproduction in whole or in part, for use other than in 
support of Maple Systems equipment is prohibited without the specific written permission of Maple Systems.

The copyright of EBPro and its related software belongs to Weintek Labs, Inc.

WARRANTY

A Warranty Statement is included with each unit at the time of purchase and is available at 
https://www.maplesystems.com.

mailto:support@maplesystems.com
https://www.maplesystems.com/
https://www.maplesystems.com/SupportCenter/Manuals&Guides.htm
https://www.maplesystems.com/SupportCenter/TechnicalNotes.htm
https://www.maplesystems.com/
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