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1. Introduction 

The Moxa EDS SNMP OPC Server is a driver of both the HMI software with OPC Client function and a real 
working data acquisition and control module OPC Server. This OPC server was implemented using advanced 
programming concepts of the most current version of the OPC specification for use in developing next 
generation industrial software applications.  
 
Key features of the Moxa EDS SNMP OPC Server. 
 
- Advanced OPC data Quality and data conversion to client's request 
- Supports Multiple Moxa EDS Devices 
- Utilizes the concept of Groups for easy configuration and manageability 
- Support standard SNMP TAG data types, such as Counter, Gauge, String…etc.   
- Internally Simulated for configuration and testing 
- Automatically create EDS Device’s Group and Tag  
- OPC Sample Client for rapid testing of your OPC data connections 
- GUI interface for viewing devices, tags, groups, and Real time data value 
- Support OPC Data Access 2.0 
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2. System Configuration and Installation 

System Requirements for Windows 2000 
- IBM PC compatible with Pentium-4 or higher  
- 128 MB RAM  
- 10 GB disk space.  
- Microsoft Win 2000 
- Standard MS SNMP API Service 
 
Hardware Support  
This OPC Server driver supports Moxa industry hub Series devices data acquisition modules. The Ethernet 
cable and wires must be present to connect the user's computer to the devices. Supported devices are as 
follows:  
ED6008, ED6008_M_SC, ED6008_S_SC, ED6008_MM_SC, ED6008_SS_SC 

 
 

2.1 Install Moxa EDS SNMP OPC Server at Windows 2000 
 
1. Insert the Moxa EDS SNMP OPC CD into the CD-ROM. 
2. run  SNMPOPC\Disk1\setup.exe 
4. Follow the instructions of the setup program. The setup program will ask you for the folder where most 

of the files will be located. 
5. The setup program will also ask you for the program folder. 
6. At the end of installation, click OK to complete and launch the OPC client application. 
 
Register OPC Server 
When you run SNMP OPC server first time, the OPC will register itself automatically. Otherwise you register 
OPC by manual as following step 
1. Invoke DOS prompt window by executing DOS execution. 
2. Change current directory to be “\Program Files\Moxa\ EDS SNMP OPC Server” 
3. Type in “SNMPOPC /RegServer” command in DOS prompt mode and execute it. 
 
Moxa EDS SNMP OPC Server would be registered into Windows system. If you want to unregistered Moxa 
EDS SNMP OPC Server, type in " SNMPOPC /UnregServer" command in DOS prompt window. (Please 
make sure current directory is “Program Files\Moxa\ EDS SNMP OPC Server”) 
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2.3 Hardware Wiring Setting 

Straight through Ethernet cable with hub.  Or the Crossover Ethernet cable.    

 

1.4 Data Types Mapping 

   The following data types are supported by the Moxa EDS SNMP device driver: 
 
 SNMP TAG Data Type   OPC data type 

INTEGER      32 bit unsigned integer 
COUNTER      32 bit unsigned integer 
GAUGE       32 bit unsigned integer 
TimerTicks      32 bit unsigned integer 
IPADDRESS      String 
Object ID       String 
STRING       String 
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Quick Start 

 
choose “program files” and click the Moxa EDS SNMP OPC Server item as the above picture 
You can retrieve the data from any Moxa EDS SNMP devices listed above by the following configuration. 
 
Step 1: Broadcast Search 
Step 2: Dedicated IP 
 
Step 1: Broadcast Search  
Using this function to search the Moxa devices in the LAN  
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After searching the devices in the LAN. The current EDS device on the Ethernet will be display in the 
following dialog box. 
to select a IP Addr. and check [OK] button, it will create a new EDS device 
 

 
 
Step 2: Dedicated IP 
 

Broadcast 
Search 
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It will display available EDS devices in the dialog box, you can choose one of this and key in IP Address by 
manual, and check [OK] button, it will create new EDS device. 
 
 

Dedicated 
IP 
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To choose the device 
 
Select one of the device, the system will create all of the tags automatically.  By OPC hierarchy, it shows 
Device->Group->Tag.   The Moxa EDS SNMP OPC Server will create the device and all of the related 
groups and the related tags.  Users do not have to create by manual.  It will save a lot of time.   
The device and groups and all of the necessary tags will be created automatically: 
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Modify the device 
Move the cursor to the Device1.  Click the right button of the mouse and choose “Property” 
 

 
 
Users could modify the device name, IP address, Timeout value and the Community. 

 
 
Name: OPC device name for OPC Client connecting 
Device Type: Defined Moxa EDS device type 
IP Address: EDS Device’s IP Address 
Timeout: Communication Timeout interval. Unit: mesc. 
Community: default value is “public”.  User can change it 
Simulate I/O: Internally Simulated for configuration and testing  
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Modify the group name 
 
To move the cursor to the group name and click the right button of the mouse and choose “Property” 

 
 
change the group name as you like 
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Modify the tag 
 
By double click the tag name, users could modify the contents of the tags as follows. 
 

 
 
 
Name: OPC TAG name 
Defined Value: 請貴公司填寫 
Description: 請貴公司填寫 
Object ID: SNMP TAG Object ID 
Data Type: OPC Data Type converted from SNMP TAG Data type, as 1.4 Data type mapping 
Number of Bytes: bytes of OPC TAG’s value for OPC internal use 
TAG Item No.: Moxa EDS SNMP TAG No. for OPC internal use 
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3. OPC Server Configuration 

3.1 OPC Server Tool 
 
The Moxa EDS SNMP OPC Server tool is your main configuration utility for setting up and maintaining the 
Moxa EDS devices driver.  It provides fields for specifying the properties of devices, groups and tags. 
 
Features 
 
Key features of the Moxa EDS SNMP OPC Server 
- Moxa EDS SNMP OPC data Quality and data conversion to client request 
- OPC server utilizes advanced free-threading capabilities. 
- Supports Multiple Groups for easy configuration and manageability 
- Create new EDS Device Group and Tag automatically 
- GUI interface for viewing tags, groups, and real time value 
- Support OPC Data Access 2.0 
 
Access Methods 
 
From the Windows Start menu: 
- Select Programs from the Start menu.  
- Select Moxa EDS SNMP OPC Server from the Programs group 
- Select Moxa EDS SNMP OPC Server execution file from the Programs submenu. 
 

4.1.1 Using the Tool's Browser 
 
The Tree Browser displays a hierarchical list of the I/O driver and its devices, groups and tags.  The I/O driver 
appears at the top of the tree. 
 
Tool Tree Browser 
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When you select an item in the Tree Browser, its properties display in the Properties Viewer.  You can choose 
to view the item's configuration or statistics properties by clicking buttons on the Run-time toolbar. 
 
Changing Items in the Tree Browser 
When you delete devices, groups or tags in the OPC Server Tool, changes are made immediately to the I/O 
Server.  Changes you make to the driver configuration while working with the OPC Server Tool automatically 
display in the Tree Browser.   
 
Collapsing and Expanding the Tree Browser 
You can collapse or expand the tree under an item by double-clicking it.   
 
Navigating in the Tree Browser 
Navigating through the Tree Browser can be done by selecting items with a mouse or by using the keyboard.  
Use the up or left arrow keys to move up in the Tree Browser.  Similarly, use the down or right arrow keys to 
move down in the Tree Browser.  You can also press a letter key to jump to the nearest item that begins with 
that letter.  
 
Additional Tree Browser Features 
Connection lines show the relationship between devices, groups and tags by displaying which devices are on a 
channel and which tags belong to a device. The plus and minus buttons indicate whether items are fully 
expanded or collapsed.  The plus button shows the item is collapsed and the minus buttons indicates that the 
item is expanded.  For example, a device with a plus sign next to it means that there are groups and possibly 
tags configured on that device. 
 
 
The Menu Bar 
 
The Tool menu bar includes a title bar, a Minimize button, a Maximize button, a Control-menu box, and the 
menus you can use to configure the driver.   
 
The Power Tool has the following menus: 
File 
Add 
Edit 
View 
Help 
 

 
4.1.2 Using Shortcut Keys 

 
The following is a list of shortcut keys for working with the I/O Driver Power Tool: 
 
 
<Ctrl>-<N>  Opens a new EDS driver configuration file.  
<Ctrl>-<O>  Allows you to open an existing file.  
<Ctrl>-<S>  Saves the current file.  
<Ctrl>-<D>  Broadcast Search 
<Ctrl>-<G>  Dedicated IP 
 

 
4.1.3 Using the File Menu 

 
The following commands appear on the File menu. 
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New 
Lets you make a new server configuration file.   
Keyboard shortcut:  <Ctrl>-<N>. 
 
Open 
Lets you open an existing server configuration file. You can select TDB file types.  
Keyboard shortcut:  <Ctrl>-<O>. 
 
Save 
Saves the current server configuration file to the default path for configuration files with the name you specify.  
The default path for configuration files is the same path where you installed the server.  You can change the 
default path by entering a new location in the Default Path tab of the Tool's Setting Defaults for I/O Driver 
Configuration File Name and Path. 
 
If you save a new server configuration file, the Save As dialog box prompts you to enter a name for your server 
configuration file. 
 
Keyboard shortcut: <Ctrl>-<S>. 
 
Save As 
Lets you enter a new name and file type for the current server configuration. 
 
Save As Dialog Box Options 
Save In Field - Lets you select the directory that you want to store the file in. 
File Name Field - Lets you save a file with a new name, or in a different location, by entering a new file 
name in the File Name field or by selecting a new directory in the Save In list.  To save a file with an existing 
file name, select the name in the list or enter the current name. 
Save as Type Field - Lets you specify the type of file you want to save the configuration as: 
 
Exit 
Exits the OPC Server Tool. 
 

4.1.4 Using the Add Menu 
 
The commands that appear in the Add menu are for creating and modifying server configuration files.  These 
commands correspond with the buttons on the Tool's Configuration Toolbar. 
 

 
 
Broadcast Search... 
Let’s you search for all of the Moxa devices in the LAN 
 
Dedicated IP... 
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Let’s you choose the correct type device and the system will create all of the device, groups and the tags 
automatically. 
 

4.1.5 Using the Edit Menu 
 
The commands that appear in the Edit menu are for cutting, copying, pasting, deleting and modifying 
configuration data.  
 

 
 
Cut 
Let’s you cut selected tag. 
 
 
Copy 
This function disabled in this system. 
 
Paste 
This function disabled in this system. 
 
Delete 
Let’s you delete selected tag. 
 
Properties... 
Let’s you define the configuration of selected devices, groups and tags. 
 
 

4.1.6 Using the View Menu 
The command let the OPC server start to communicate with the devices. 

 
 
Monitor 
Start to communicate with the devices.  All of the value will show on the right screen. 
If the communication failed,  it will show you “bad” 
 
Status Bar 
It will disable the status bar on the bottom of the screen or enable the status. 
 

4.1.7 Using the Help Menu 
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About SNMPOPC... 
Displays related information of the OPC server version and the copyright. 
 
 
 
 

3.2 Configuring the I/O Driver with the Tool 
 
To modify the fields in the Properties Viewer 
1. Select a device, group or tag from the Tree Browser and click the properties button in the Edit menu. The 

fields for the selected item appear in the Properties Viewer. 
2. Edit the fields you want to change. 
 
 

4.2.1 Modifying Devices 
 
To modify an existing device 
1. Select the device you want to modify from the Tree Browser.   
2. Select specified device and click on Properties button in the Edit menu bar. Device Properties dialog will be 

pop up for device modification 
3. Edit the device's fields as needed.  
 

 
 
Device Name 
Specifies the name of the modified device.  
 
Valid Entries: Up to 12 alphanumeric characters 
 
Device Type 
It can not be modified by the users. 
 
IP Address 
Specifies which IP address to use for the selected device. You can specify the IP address as necessary for 
communication with your hardware.   
 
Timeout 
Specifies how long the I/O driver waits for a response from the selected device. The base of timeout field is 
mini-second. For example, if you specify 1000 in this field, server will wait for a response about 1000 
mini-second (equal to 1 second). 
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Valid Entries: 
1 ~ 65535 

 
Community: default value is “public”. 
 
Simulation I/O 
Specifies the device to be a virtual device. It does not connect to any physical devices. But it would provide a 
simulation signal to the server. 
 
Valid Entries: 
Enabled 
Disabled 
 
To delete an existing device 
1. Select the device you want to delete from the Tree Browser. 
2. Click on Delete button in the Edit menu bar. 
 
 

4.2.2 Modifying Tag Groups 
 
To modify an existing group 
1. Select the group you want to modify from the Tree Browser. 
2. Select Properties button from Edit menu bar. Group properties dialog will pop up for modification.  
 

4.2.3 Modifying Tags 
 
To modify an existing tag 
1. Select the tag you want to modify from the Tree Browser.   
2. Click on Properties button in the Edit menu bar. Tag Properties dialog will be pop up for tag modification 
3. Edit the tag's fields as needed 
 
Tag Name 
Specifies the name of modified I/O tag.  
 
Defined Value：請貴公司填寫 
Valid Entries 
Up to 80 alphanumeric characters and symbols. 
 
Data Type 
OPC Data Type converted from SNMP TAG Data type (can not be modified) 
See 1.4 Data type mapping 
 
Description：請貴公司填寫 
Valid Entries 
Up to 80 alphanumeric characters and symbols. 
 
Object ID 
SNMP TAG Object ID (can not be modified) 
 
Number of Bytes 
bytes of OPC TAG’s value for OPC internal use 
 
TAG Item No. 
Moxa EDS SNMP TAG No. for OPC internal use 



 20

5. Using OPC Client 

An OPC Client application, provided with the Moxa EDS SNMP OPC Server, has rapid methods for 
connecting your Servers. The OPC Client is able to browse the registry of a PC and display a complete list of 
all installed OPC Servers. It also provides real live data feedback and OPC Server browsing capabilities. 
The OPC Client is also helpful for connecting and testing other 3rd party OPC applications connected to same 
server. 
 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Connect the OPC 
Server
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Add the tags to watch 
 
press the ADD icon and choose the necessary tags you want to monitor. 

 
 
It will show you the value of the of the tags. 

 
 
 
 
 
 
 
 
 
 
 
 

Add Item 
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Write the value to the OPC Server 
You can click the “Write Item” button and key in the value you want. 

 
 
Features 
- Setup dialog box for defining the default name and default setting for configuration files. 
- Tree Browser for an overall view of your system setup. 
- Moveable Tree Browser and toolbars. 
 
 
 
 
 

5.1 Connecting OPC server 
 
When OPC servers are installed on the system, they are registered so that clients can find them and users can 
view them in a list. To make a client/server connection, the user must first choose a server. The server name 
selected (for example, Moxa.SNMPOPC) is used to get a class ID which, in turn, is used to create a COM 
object. If the user selects a server that is not currently running, the system starts the server and then creates the 
object in that server on behalf of the client. 
 
Once the COM object is created, the client application has an IOPCServer interface, as defined in the OPC 
specification. This is the main interface to the OPC server and this document refers to this as a Server interface. 
(The other interface is Group.) This OPC client always creates a group and registers an device interface with it 
to get asynchronous data notification. 
 
When an item is added, the dialog displays either a hierarchy or a flat list of names, depending on the server. 
The names are queried from the Server object using the filter string and requested data type. When the user 
either types or selects a name, an item by that name is added to the Group object. This item is also read 
immediately to get an initial value. 
 
Items in a group are scanned by the server; when their values change, the advise interface in the client is 
notified. A data structure containing the data for each item whose value or quality has changed (and only those 
items) is passed to the client devise interface. The client unpacks and uses the data. 
 
Server status and Group parameters 
The Server status dialog periodically queries the Server object for status and displays the results. The Group 
Parameters dialog queries the group state and displays the results. The OK or Apply buttons in the Group 
Parameters dialog box write the parameters from the dialog to the Group object and read the parameters back. 
This primarily controls the scanning and updating of data. When a group is inactive, it does not send data 
notifications to the client and, typically there is no reason to scan the items when the group is inactive. The 
Update Rate in the Group Parameters dialog box specifies the rate at which data notifications should be sent 

To write 
the value to 
the OPC 
server 
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back to the client, assuming that data has changed. This is also the rate at which items are scanned on behalf of 
this client. 
 
To write a value to an item, select the item in the OPC Client windows and choose Writer Value to Item from 
the OPC menu, The client writes the value typed in the Write Item Value dialog box to the correct item in the 
Group object. The method of writing data is determined by the synchronous checkbox. When data is written 
synchronously, the call to the server blocks until the operation has completed, which may take a long time. 
When data is written asynchronously, the call to the server returns quickly and the operation is carried out on 
another thread. When the write has finished, the client devise interface is notified with the results. 
 
The user can disconnect from the selected server by choosing Disconnect from the OPC menu, The Disconnect 
command un-registry the devise interface, releases the Group object, and then releases the Server object. 
Releasing an object means that the client is no longer interested in the object, so the system can delete the 
object in the server. 
 
Server State Dialog Box 

 
 
Start Time: the time the server started running 
 
Last Time: the last update time from the server 
 
Current Time: the current time from the server. 
 
Groups: number of connected group 
 
Bandwidth: The behavior of this field is server specific.  A suggested use is that it return the approximate 
Percent of Bandwidth currently in use by server.  If multiple links are in use it could return the ‘worst case’ 
link.  Note that any value over 100% indicates that the aggregate combination of items and UpdateRate is too 
high.  The server may also return 0xFFFFFFFF if this value is unknown. 
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Group Parameter Dialog Box 
[Remark: It can define only one group in Sample OPC Client utility] 
 

 
 
Name: group’s name 
 
Update Rate: the update rate (in milliseconds) for OPCGroups 
 
Active: active state for OPCGroups 
 
Deadband: The range of the Deadband is from 0.0 to 100.0 Percent. Deadband will only apply to items in the 
group that have a dwEUType of Analog available. If the dwEUType is Analog, then the EU Low and EU High 
values for the item can be used to calculate the range for the item. This range will be multiplied with the 
Deadband to generate an exception limit. An exception is determined as follows: 

Exception if (absolute value of (last cached value - current value) > (pPercentDeadband/100/0) * (EU High - 
EU Low) ) 
 
Time Bias: The purpose of the TimeBias is to indicate the timezone in which the data was collected 
LCID: Group Local ID 
 
 
 
 


